Author Topic: [solved]After skipping a song gmusicbrowser is muted!  (Read 2520 times)

staubi

  • Jr. Member
  • **
  • Posts: 57
    • View Profile
I just discovered a really annoying thing:

When I skip a song gmb doesn't play any more songs until I restart it! I can still play sounds with other programs though....


I use gstreamer (0.10.36-4) for playback!

I don't skip songs that often since I usually create playlists with what I want to hear, but still...

Any ideas?
« Last Edit: May 11, 2014, 17:36:36 by staubi »

Quentin Sculo

  • Administrator
  • Hero Member
  • *****
  • Posts: 1082
    • View Profile
Re:After skipping a song gmusicbrowser is muted!
« Reply #1 on: May 11, 2014, 02:22:37 »
Can you provide more details, like does it play with no sound, or display an error message ...
Also what audio options are you using (in the audio tab of the preferences dialog) ?
If you use pulseaudio, you can launch pavucontrol and see if gmusicbrowser is listed in the apps playing.

staubi

  • Jr. Member
  • **
  • Posts: 57
    • View Profile
Re:After skipping a song gmusicbrowser is muted!
« Reply #2 on: May 11, 2014, 17:36:12 »
Can you provide more details, like does it play with no sound, or display an error message ...
It just looks like it plays normally. No error message, also nothing in terminal, if I start it there...
Quote from: Quentin Sculo
Also what audio options are you using (in the audio tab of the preferences dialog) ?
I use gstreamer with automatic output. I just tried changing ithe output to alsa or pulseaudio (and restarting gmb) with no effect...
Also I had checked the "Ignore errors"-box, but it also didn't change anything unchecking it!

Quote from: Quentin Sculo
If you use pulseaudio, you can launch pavucontrol and see if gmusicbrowser is listed in the apps playing.

...and this solved it!!! pavucontrol showed gmb playing and in the bottom I could see the sound level moving, but the volume for gmb was set to about 5% !?!
After adjusting it works now! I just don't get what happened! Pavucontrol was not installed before and this behaviour just came one day...

Anyway: Thanks for Your help Quentin!

raimo31

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: [solved]After skipping a song gmusicbrowser is muted!
« Reply #3 on: June 12, 2014, 21:18:49 »
I got a similar problem, no sound after doing "next" or "skip" . The song played normaly in the progress bar but no sound. I was obliged to restart Gmusic, but the sound was for the first song.
Finally , thanks to staubi I just solved the issue by  adjusting the sound level.
I'm using Kubuntu 14.04 / 64 bits.  The problem appeared after the validation of some pluggin.

May be this story could help !

Thanks for this wonderful music player and moreover, more than a player.
Kubuntu, 14.04 / 64