Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - tumza

Pages: [1]
1
Questions / Re: Cannot Launch gmb (BEGIN failed) [Solved]
« on: June 11, 2016, 03:29:20 »
It was already fixed in https://github.com/squentin/gmusicbrowser/commit/853840eb9dad0b59ad2dac5d303f5929b2f09f21

I applied the two fixes within commit 853840eb9dad0b59ad2dac5d303f5929b2f09f21 and now it's running.

Thanks.

2
Questions / [Solved] Cannot Launch gmb (BEGIN failed)
« on: June 09, 2016, 05:40:56 »
Hi, I have not been able to launch gmb after a recent system reboot.

This is the result I get from the terminal:

Quote
Can't redeclare "my" in "my" at /usr/bin/../share/gmusicbrowser/gmusicbrowser_list.pm line 8055, at end of line
Compilation failed in require at /usr/bin/gmusicbrowser line 442.
BEGIN failed--compilation aborted at /usr/bin/gmusicbrowser line 475.

Your assistance is greatly appreciated.

3
Questions / Restart Now Playing Song
« on: April 27, 2016, 03:26:43 »
Hi, currently the "Previous" or "Recently played songs" button plays the previous song when clicked while playing a song.

Is there a setting I can change to make the currently playing song to go to the beginning or restart instead when I click that same button?

Thank you.

4
Questions / Re: gmb crashes when skipping to an .m4a file
« on: August 27, 2015, 22:21:07 »
Quote
It looks like a gstreamer bug.
Have you activated the gapless option ? (look for the "advanced options" button in the audio tab) Try without gapless if it was checked.

No gapless is not activated. But what was activated was the "Use ReplayGain" option in the audio tab. I just deactivated it now and that seems to have  solved the problem.

However, I re-activated ReplayGain again to see if it was the cause but cannot reproduce the bug again.

Thanks for all your help and an amazing app.

5
Questions / Do Not Sort Artists By The Article "The"
« on: August 24, 2015, 21:11:47 »
Quote
It would be much more convenient if artists' names starting with "The" are sorted by their name not by the article "the" (e.g. finding The Who under the letter "w" instead of "t")...

This is from an old post. I was wondering if it has been implemented yet? I still find The Who sorted under T and not W, where I would first go look.

6
Questions / Re: gmb crashes when skipping to an .m4a file
« on: August 23, 2015, 13:50:07 »
I am using gstreamer 1.x

This is the error message from the terminal:

Quote
GLib-CRITICAL **: init_zone_from_iana_info: assertion 'size >= sizeof (struct tzhead) && memcmp (header, "TZif", 4) == 0' failed at /usr/bin/gmusicbrowser line 7522.
GLib-CRITICAL **: interval_offset: assertion 'tz->t_info != NULL' failed at /usr/bin/gmusicbrowser line 7522.
Segmentation fault (core dumped)

and this is the error message when playing a different .m4a track:

Quote
GLib-CRITICAL **: init_zone_from_iana_info: assertion 'size >= sizeof (struct tzhead) && memcmp (header, "TZif", 4) == 0' failed at /usr/bin/../share/gmusicbrowser/gmusicbrowser_list.pm line 7353.
GLib-CRITICAL **: interval_offset: assertion 'tz->t_info != NULL' failed at /usr/bin/../share/gmusicbrowser/gmusicbrowser_list.pm line 7374.
*** Error in `/usr/bin/perl': double free or corruption (fasttop): 0x00007f418801a000 ***
Segmentation fault (core dumped)

7
Questions / gmb crashes when skipping to an .m4a file
« on: August 16, 2015, 15:48:45 »
Hi. Recently I have been experiencing gmb crashing (quitting) when skipping to an .m4a file/track or when the next track in the playlist is an .m4a file. Strangely, this does not happen every time, sometimes it can play the first two .m4a tracks and then quit on the third or sometimes it just quits when starting the first track. What could be the cause?

8
Quote
I think simply reinstalling the perl-glib-object-introspection package from AUR should do the trick.

Perfect! Thank you very much!

9
Quote
It seems perl-glib-object-introspection on my config wasn't rebuild properly when updating. Did it manually once more and gb started correctly and everything works fine now.
I have the exact same second error on 64-bit Arch system. How did you manually rebuild the perl-glib-object-introspection on your config? Thanks.

Pages: [1]