Author Topic: Default rating is set to 0 for a while now, but I want 50 ;)  (Read 2809 times)

staubi

  • Jr. Member
  • **
  • Posts: 57
    • View Profile
Hi, I realized a while ago that newly added music has a default rating of 0% even though in settings the default rating is set to 50%.

What I do right now is to manually set it after having added new tracks, but that's somehow annoying.

Any idea on what might be the problem?

Quentin Sculo

  • Administrator
  • Hero Member
  • *****
  • Posts: 1095
    • View Profile
Re: Default rating is set to 0 for a while now, but I want 50 ;)
« Reply #1 on: May 11, 2014, 02:30:09 »
That's strange, can you show me a screenshot of the properties dialog of a song that you have just added ?

staubi

  • Jr. Member
  • **
  • Posts: 57
    • View Profile
Re: Default rating is set to 0 for a while now, but I want 50 ;)
« Reply #2 on: May 11, 2014, 18:06:32 »
OK, here are the screenshots. Strange enough the propertie dialog says the song has a default rating of 50, but even if I save the properties it remains on 0%.
Probably I ought to mention that I use the epic-rating addon. So if I listen 5 times to a new song it gets a rating of 25% (adds 5% everytime a song is played completely).

Quentin Sculo

  • Administrator
  • Hero Member
  • *****
  • Posts: 1095
    • View Profile
Re: Default rating is set to 0 for a while now, but I want 50 ;)
« Reply #3 on: May 12, 2014, 01:33:00 »
I think it's working as it's supposed to, newly added songs do not actually get a default rating, it stays undefined, and when a rating is needed, the current default rating is used.
The problem may be in the epic-rating plugin, when the changing the rating of a song that has no rating, it should start from the default rating rather than 0.