Author Topic: GMB auto-playing tracks when I'm browsing  (Read 206 times)

riccardo

  • Newbie
  • *
  • Posts: 6
    • View Profile
GMB auto-playing tracks when I'm browsing
« on: June 18, 2020, 17:42:56 »
First up before I ask my question as this is my first post here I figure it's only right that I give thanks for one of my two absolute favourite pieces of software in the world. I've used it pretty much every day for the last decade as the whole world seems to have gone crazy with cruddy streaming services and I wouldn't be without it. Occasionally had a look at shiny looking alternatives but none of them touch the functionality of GMB.

That said there's this one thing that's bugging me.

I like to browse my collection while listening to music in the order I've queued up. When I'm doing this the left click behaviour when I select an album to display the contents is inconsistent. Sometimes it just displays the track details, sometimes it also starts playing the first track on the album.

Trying to train myself to default to the right click but not doing too well, TBH. Not to mention the right click gives me a menu I don't usually want. Is there any way to modify the left click behaviour? Something in the settings I've missed? Or is it a bug?
« Last Edit: June 18, 2020, 17:55:41 by riccardo »

Quentin Sculo

  • Administrator
  • Hero Member
  • *****
  • Posts: 1087
    • View Profile
Re: GMB auto-playing tracks when I'm browsing
« Reply #1 on: June 23, 2020, 18:22:33 »
It may be due to the layout you are using, which one are you using and where are you clicking on an album, maybe post a screenshot ?

riccardo

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: GMB auto-playing tracks when I'm browsing
« Reply #2 on: June 24, 2020, 19:01:59 »
Ha! If there's a chance the layout may be culpable that's probably it. I'm using my own bodged modification which I think started out as the "Lists, Library & Context" default a long time ago.

I've attached a screenshot of my Library view. I don't have the tabs shown in the three navigation panels but basically the one on the left is "Lists", the middle one is "Album artist or artist" and the one on the right is "Album". Besides the "Lists" panel the other two panels are both set to mosaic mode with "huge" album art. The unwanted auto-playing happens when I'm left clicking on any item in either of these two panels in mosaic mode.

Quentin Sculo

  • Administrator
  • Hero Member
  • *****
  • Posts: 1087
    • View Profile
Re: GMB auto-playing tracks when I'm browsing
« Reply #3 on: June 25, 2020, 20:53:59 »
Can you show me the layout ?

riccardo

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: GMB auto-playing tracks when I'm browsing
« Reply #4 on: June 25, 2020, 21:03:19 »
I certainly can!

Code: [Select]
[Custom 1]
Type=G+
Default = Window(size=1440x900)
VolumeScroll = VBplayer
DefaultFocus = Play
Name = _"Custom 1"
VBmain = HBtop _HPmain
     
 HBtop = VBButtons _15VBPlayer -5VBSettings
      VBButtons = HBButtons
HBButtons = Prev Play Next(click2=NextAlbum)
      VBPlayer = HBTitle VBTime
HBTitle = Title(expand_max=300,markup="<big><b>%t</b></big> ",tip=_"Title: %t (Track
No. %n)".if($track,pesc($track)),yalign=0.5,ellipsize=end) LockAlbum(stock="on:gmb-lock gmb-lockopen
off:gmb-breadcrumb gmb-locklight") Album(tip=_"Album: %l
(%Y)",expand_max=200,yalign=0.5,markup="<big> </big>%l ",showcover=0,ellipsize=end)
LockArtist(stock="on:gmb-lock gmb-lockopen off:gmb-breadcrumb gmb-locklight") Artist(tip=_"Artist:
%a",expand_max=200,yalign=0.5,markup="<big> </big>%a",ellipsize=end)
VBTime = _HBTimeSlider _SimpleSearch(suggest=1)
  HBTimeSlider = PlayingTime(markup="%s",initsize="XX:XX",xalign=0)
_TimeSlider(direct_mode=1) -Length(markup="$length",initsize="XX:XX",xalign=1)
      VBSettings = HBPrefSearch 5Filler5
HBPrefSearch =
ToggleButton0(size=large-toolbar,relief=none,icon=gtk-find,widget=SimpleSearch) ExtraButtons
BMSettings
  BMSettings = (icon=gtk-preferences,size="large-toolbar") SMLibrary LayoutItem PlayItem
SeparatorMenuItem01 MenuItem34(command=OpenCustom(Equalizer),label=_"Equalizer") SeparatorMenuItem20
MenuItem14(command=OpenPref,label=_"Settings",icon="gtk-preferences")
MenuItem05(command=Quit,label=_"Quit",icon="gtk-quit")
    SMLibrary = (label=_"Library")
MenuItem00(command="RunPerlCode(::ChooseAddPath(1,1))",label=_"Add Music",icon="gtk-add")
MenuItem32(command="RunPerlCode(::IdleScan)",label=_"Rescan Collection",icon="gtk-refresh")

 HPmain = _TBRight
  TBRight = _"Library" VPRight _"Context" PictureBrowser _"Queue" VPWrong
   VPRight = HPfp0 _VBSongList
    HPfp0 = FilterPane0(nb=1,hidebb=1,page=genre) HPfp1
     HPfp1 = FilterPane1(nb=2,hidebb=1,page=artist,page_artist/lmarkup=1) \
  FilterPane2(nb=3,hidebb=1,page=album,page_album/lpicsize=50,page_album/lmarkup=1)
    VBSongList = HBSongList _SongTree
     HBSongList = -MBlist
      MBlist = PlayItem
   VPWrong = MBBill HBTed
    MBBill = QueueItem PSortItem
    HBTed = _QueueList

Quentin Sculo

  • Administrator
  • Hero Member
  • *****
  • Posts: 1087
    • View Profile
Re: GMB auto-playing tracks when I'm browsing
« Reply #5 on: July 01, 2020, 21:33:28 »
I can't reproduce the problem.
Does it happen every time you click on these 2 panels ?
One possibility is that you are double-clicking without wanting to. To check this you could change the activate option from the default "play" to "queue" :
Code: [Select]
     HPfp1 = FilterPane1(nb=2,hidebb=1,activate=queue,page=artist,page_artist/lmarkup=1) \
  FilterPane2(nb=3,hidebb=1,activate=queue,page=album,page_album/lpicsize=50,page_album/lmarkup=1)

Otherwise I don't know, to investigate a bit you could add the warn line like below (search for "sub SetFilter" in /usr/bin/gmusicbrowser)
Code: [Select]
sub SetFilter
{ my ($object,$filter,$level,$group)[email protected]_;
warn "SetFilter: object=$object filter=$filter level=$level group=$group\n";
This should tell you what group you are changing when clicking, if it was the group "Play" it would change the playlist, but it's not in your layout so it shouldn't be the case.

riccardo

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: GMB auto-playing tracks when I'm browsing
« Reply #6 on: July 02, 2020, 01:03:32 »
That appears to have fixed it! Thankyou.

It wasn't happening every time I clicked on those two panels, it happened intermittently but often. Out of every ten artists or albums I clicked on it would autoplay maybe four or five but I couldn't figure out any pattern in the years (literally) this has been bugging me. I'm as sure as can be I wasn't double clicking, unless somehow it was reading a single click as a double? In any case I've been playing with it for half an hour now deliberately clicking on as many covers as possible and playback hasn't been interrupted a single time so it appears all but certain that changing the activate option has either fixed or worked round the problem.

Thanks again for your help and for a fantastic piece of software.

riccardo

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: GMB auto-playing tracks when I'm browsing
« Reply #7 on: July 02, 2020, 01:18:26 »
Update: looks like I spoke a little too soon. It's now intermittently adding songs to the queue, which is less irritating but still not ideal. I'll try your suggested route of investigation and see if I can figure out any more clues.

Quentin Sculo

  • Administrator
  • Hero Member
  • *****
  • Posts: 1087
    • View Profile
Re: GMB auto-playing tracks when I'm browsing
« Reply #8 on: July 02, 2020, 06:04:10 »
It really looks like you are double clicking with your mouse without wanting to, it happened to me with some mice.
You can replace the "queue" with for instance "nothing" like below, it will print an harmless error on the terminal as 'nothing" is not a known action, but it will do nothing.
But it seems the real problem is with your mouse.

Code: [Select]
     HPfp1 = FilterPane1(nb=2,hidebb=1,activate=nothing,page=artist,page_artist/lmarkup=1) \
  FilterPane2(nb=3,hidebb=1,activate=nothing,page=album,page_album/lpicsize=50,page_album/lmarkup=1)

riccardo

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: GMB auto-playing tracks when I'm browsing
« Reply #9 on: July 02, 2020, 17:39:20 »
You may have a point about the mouse. I wasn't sure at first because I couldn't remember having the problems in other applications, then I remembered a few cases of links opening up twice so that's probably it. This also means I've had two bad mice in a row.

In any case your workaround works a treat, I can live with the error messages, so thanks again.