Author Topic: Library stays empty  (Read 5978 times)

elfarto

  • Newbie
  • *
  • Posts: 5
    • View Profile
Library stays empty
« on: January 11, 2012, 04:02:56 »
Dear all,

I'm having a strange problem.
I just reinstalled ubuntu 10.10 because on my Eeepc it's working way faster than one of the 11.xx-versions.
I just did a clean install of the 1.1.8 and it seems impossible to add my music folder to Gmusicbrowser.
My library is just staying empty  :'(
First I thought it had something to do with the file permissions, I changed them all to read&write, but it didn't change anything...
I tried to find some answers by using some search engines, but nothing found?!
Am I really the only one having this same problem?

Quentin Sculo

  • Administrator
  • Hero Member
  • *****
  • Posts: 1082
    • View Profile
Re: Library stays empty
« Reply #1 on: January 12, 2012, 01:00:14 »
I don't know what could cause that, could you run it from a terminal and show me what it says when you try to add music ?

elfarto

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: Library stays empty
« Reply #2 on: January 12, 2012, 11:56:36 »
Thank you for your reply!
When I startup gmusibrowser from terminal, I'm getting the following output:

Reading saved tags in /home/elfarto/.config/gmusicbrowser/gmbrc ...
Reading saved tags in /home/elfarto/.config/gmusicbrowser/gmbrc ... done
These commands were not found : mpg123, flac123, mpg321, ogg123
 => these file types won't be played by the 123 output : mp3, oga, flac
Use of uninitialized value $_[0] in vec at (eval 109) line 1.
Use of uninitialized value $_[0] in vec at (eval 110) line 1.
Use of uninitialized value $_[0] in vec at (eval 109) line 1.
Use of uninitialized value $_[0] in vec at (eval 110) line 1.

elfarto

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: Library stays empty
« Reply #3 on: January 12, 2012, 11:59:13 »
When I'm scanning, I'm getting:

ScanFolder(/home/elfarto/Music/Agoria/Blossom)

and it's just displaying all the folders he's actually scanning (quite fast), when it's finished, nothing happens...

Quentin Sculo

  • Administrator
  • Hero Member
  • *****
  • Posts: 1082
    • View Profile
Re: Library stays empty
« Reply #4 on: January 12, 2012, 21:18:21 »
2 things to check :
1) if the "do not add songs that cannot be played"  is checked (settings dialog, library tab), it's not by default, but if checked and for example the audio output you selected doesn't support mp3, it won't add mp3 files ...
2) if the "use a master filter" is checked, un-check it

elfarto

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: Library stays empty
« Reply #5 on: January 13, 2012, 02:47:58 »
Thanks for the advice. However I'm still having the same problem.
Anyway I'm not gonna speak one bad word about your amazing software!
It's just that now I'm so addicted to it that I can't live without it anymore  :P

elfarto

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: Library stays empty
« Reply #6 on: January 14, 2012, 15:12:04 »
O my god! I feel so stupid!
I just found the cause: I had to copy my files from my ipod since my external harddrive crashed.
While copying the files, the software I used didn't put the extension (for example .mp3) behind the filename!
You can close the topic, thank you very much for your help!