Author Topic: New issues in Natty build  (Read 3523 times)

VastOne

  • Full Member
  • ***
  • Posts: 200
    • View Profile
New issues in Natty build
« on: March 30, 2011, 10:07:50 »
Nothing new was updated on my GMB setup, but something has come through the Natty updates that is now causing the following message on both squentin and the shimmer project build:

Code: [Select]
Gtk2::TrayIcon not found -> tray icon won't be available
GStreamer.pm not found
 -> gstreamer output won't be available.

Again, everything on both are up to date and had been working fine. I noticed that the tray icon was missing so I ran from terminal and the above lines are the first displayed.

I also use a trayicon from .config and have never had an issue until today...

Also MPRIS2 seems to be no longer working as GMB is not showing up in the volume tray anymore in Natty but it is working fine on the xfce Natty build...(shimmer) .. 
« Last Edit: March 30, 2011, 10:40:44 by VastOne »

Quentin Sculo

  • Administrator
  • Hero Member
  • *****
  • Posts: 1082
    • View Profile
Re: New issues in Natty build
« Reply #1 on: March 30, 2011, 11:10:09 »
It seems the library used only by gmusicbrowser are not installed, maybe they were uninstalled because you don't have a gmusicbrowser deb package installed, and so those libraries were considered orphans =>not needed.
You can simply re-install them :
libgstreamer-perl
libgtk2-trayicon-perl
libnet-dbus-perl

VastOne

  • Full Member
  • ***
  • Posts: 200
    • View Profile
Re: New issues in Natty build
« Reply #2 on: March 30, 2011, 11:22:00 »
It seems the library used only by gmusicbrowser are not installed, maybe they were uninstalled because you don't have a gmusicbrowser deb package installed, and so those libraries were considered orphans =>not needed.
You can simply re-install them :
libgstreamer-perl
libgtk2-trayicon-perl
libnet-dbus-perl


Thanks Quentin,   that did restore the tray icon

It is not showing up in the volume tray though.. like it has before and also does in Xfce Natty

I do not use that so it is not a big deal to me... Just info for you and Ochosi

VastOne

  • Full Member
  • ***
  • Posts: 200
    • View Profile
Re: New issues in Natty build
« Reply #3 on: March 30, 2011, 12:00:50 »
I installed the deb in Natty, still using your git,  and now the Volume tray is correctly working...

So it was all a dependency issue

Thanks...
« Last Edit: March 30, 2011, 12:23:48 by VastOne »