Author Topic: Is the libre.fm plugin broken?  (Read 3418 times)

pyropingvin

  • Newbie
  • *
  • Posts: 15
    • View Profile
Is the libre.fm plugin broken?
« on: March 24, 2011, 23:17:32 »
Is the libre.fm plugin broken? There is no option to choose between last.fm or libre.fm, you can only use last.fm. How can I fix to scroble in libre.fm?

PS: I use gmusicbrowser 1.1.7-1 on debian sid.

ochosi

  • Full Member
  • ***
  • Posts: 187
    • View Profile
Re: Is the libre.fm plugin broken?
« Reply #1 on: March 25, 2011, 02:19:58 »
the option to choose between libre.fm and last.fm is currently only maintained in my fork of gmusicbrowser. we had discussions about this but at least up to now this change hasn't gone upstream and therefore isn't featured in 1.1.7, neither in debian nor in ubuntu.

what you can do for the time being is manually grab the plugin from my git-repo and replace your last.fm in /usr/share/gmusicbrowser/plugins with it.

pyropingvin

  • Newbie
  • *
  • Posts: 15
    • View Profile
Re: Is the libre.fm plugin broken?
« Reply #2 on: March 25, 2011, 21:06:09 »
Thanks, it works.

I have tried the same but I've put the plug-in ~/.config/gmusicbrowser/plugin but with the up-date 1.1.7 version for some reason it didn't work. 

ochosi

  • Full Member
  • ***
  • Posts: 187
    • View Profile
Re: Is the libre.fm plugin broken?
« Reply #3 on: March 25, 2011, 23:28:16 »
well i assume if there are two conflicting plugins (meaning: two plugins registering the same name) the one in /usr/share overrides the one in /home/$user/

but i haven't looked at the code, so this is pure speculation.