Author Topic: [Résolu] Dysfonctionnement de la liste de lecture + quelques problèmes  (Read 6531 times)

mgrubert

  • Sr. Member
  • ****
  • Posts: 369
    • View Profile
Je sens que je bidouille trop le bousin, mais bon je te signale les problèmes que je rencontre.

Ce soir je démarre GMB comme d'habitude, il se lance, interface normale, sauf qu'impossible de lancer une chanson : aucune ne démarre.
Je cherche à droite à gauche : quand je met des chansons en queue, la queue passe de l'une à l'autre, comme si elles étaient illisibles et qu'il sautait à la suivante, sauf que toutes sont illisibles, donc la queue se vide sans aucun son. Les mêmes chansons marchent sur Rhythmbox pourtant.

La dernière chose que j'ai faite qui me semble en rapport est d'utiliser Ubuntu-tweak pour faire un nettoyage des restes sur l'ordi (dont les fichiers de conf inutilisés).

N'y tenant pas (ça me saoule d'utiliser Rhythmbox), je décide de tenter une réinstallation. Le sudo make install depuis le répertoire git ne donne rien de mieux. Je vais dans Synaptics et constate que GMB est repéré comme non installé (dans Synaptics (je l'avais viré avant de le réinstaller par git, make install et tout)). J'installe depuis Synaptics, puis enchaîne directement sur un sudo make install depuis le répertoire git.

Je relance. Ça refonctionne. Enfin presque tout sauf une chose : quand je double clique sur un album pour le lire, il me met dans la liste de lecture une seule chose : le nom de l'album ! Il lit la première chanson de l'album et s'arrête. En passant par la queue tout fonctionne.

Une idée ?

PS : Je ne pige pas : c'est moi ou je m'attire tous les ennuis possibles ?
« Last Edit: January 29, 2011, 18:53:23 by mgrubert »

Quentin Sculo

  • Administrator
  • Hero Member
  • *****
  • Posts: 1082
    • View Profile
Re: Quelques problèmes
« Reply #1 on: January 26, 2011, 02:54:59 »
Le premier problème vient probablement du fait qu'ubuntu-tweak a désinstallé des librairies dont seul gmb se servait, et comme il était pas officiellement installé, ubuntu a considéré ces librairies orphelines...

Quote
Je relance. Ça refonctionne. Enfin presque tout sauf une chose : quand je double clique sur un album pour le lire, il me met dans la liste de lecture une seule chose : le nom de l'album ! Il lit la première chanson de l'album et s'arrête. En passant par la queue tout fonctionne.
Je suis pas sûr de ce qui ce passe, une possibilité est le mode "attente" de la liste d'attente (si la mémorisation de la liste d'attente est activé, le mode "attente" et "auto-remplissage" sont mémorisé aussi s'ils ont activés.) Sinon je dais pas, une capture d'écran pourrait aider peut-être...

mgrubert

  • Sr. Member
  • ****
  • Posts: 369
    • View Profile
Re : Quelques problèmes
« Reply #2 on: January 26, 2011, 03:04:27 »
J'ai pensé à ça aussi pour Ubuntu-tweak.
Pour la file d'attente, je ne sais pas si une capture est nécessaire.
En gros, je double clique sur l'album, et seule la première chanson est dans la file d'attente, alors que hier c'était tout le disque (et même les disques suivants dans la liste des disques qui s'affichaient à la suite dans la liste de lectute). Et une fois que la chanson est finie, GMB stoppe (enfin il ne s'arrête pas : il arrête de lire des chansons).

Quentin Sculo

  • Administrator
  • Hero Member
  • *****
  • Posts: 1082
    • View Profile
Re: Quelques problèmes
« Reply #3 on: January 26, 2011, 03:25:42 »
Comme je l'ai dit le mode 'attente' de la file d'attente peut être activé. Mais comme l'interface de gmb est très configurable, c'est difficile d'indiquer un endroit précis où regarder...
Aussi le layout peut changer le comportement par défaut lorsqu'on double-clic sur une chanson.
Donc sait-tu quel layout (disposition) tu utilises ? (préférences->apparence de la fenêtre)

mgrubert

  • Sr. Member
  • ****
  • Posts: 369
    • View Profile
Re : Quelques problèmes
« Reply #4 on: January 26, 2011, 03:42:21 »
Je suis sous arkanoid, mais même quand me mets sous le layout Liste de lecture, Biblio et Contexte, le problème est le même (depuis hier, avant aucun pb sous aucun layout)

Quentin Sculo

  • Administrator
  • Hero Member
  • *****
  • Posts: 1082
    • View Profile
Re: Quelques problèmes
« Reply #5 on: January 26, 2011, 04:05:37 »
Vérifie si le mode 'attendre une fois la file d'attente vide' est activé, le layout "Liste de lecture, Biblio et Contexte" a un menu "file d'attente" qui permet de changer le mode de la file d'attente.

mgrubert

  • Sr. Member
  • ****
  • Posts: 369
    • View Profile
Re : Quelques problèmes
« Reply #6 on: January 26, 2011, 04:11:07 »
Non, c'est en "mode normal".
Je pense que le problème vient d'autre chose que les multiples choix qu'offrent GMB. Il doit y avoir un bug causé par mes manips. Mais je ne sais pas comment le résoudre.
Un conseil pour tout virer (sans perdre les pochettes de disques, pitié, donc sans perdre le .config/gmusicbrowser) et tout remettre à zéro ?

Quentin Sculo

  • Administrator
  • Hero Member
  • *****
  • Posts: 1082
    • View Profile
Re: Quelques problèmes
« Reply #7 on: January 26, 2011, 04:32:05 »
Tout est sauvegardé dans ~/.config/gmusicbrowser/gmbrc il y a même quelques backups dans le répertoire.
Donc il suffit de le déplacer/renommer, ou on peut aussi utiliser l'option -cfg pour lui faire utiliser un autre répertoire ou fichier (le fichier n'a pas besoin d'exister) :
gmusicbrowser -cfg /tmp/ceci_est_un_test

mgrubert

  • Sr. Member
  • ****
  • Posts: 369
    • View Profile
Re : Quelques problèmes
« Reply #8 on: January 26, 2011, 04:44:07 »
Écoute je verrai ça demain (ou plus tard).
Mon intention est de tout supprimer par synaptic, ubuntu-tweak, tout en conservant une sauvegarde manuelle des fichiers de configuration.
Je te tiens au courant des suites de cette affaire.

mgrubert

  • Sr. Member
  • ****
  • Posts: 369
    • View Profile
Re : Quelques problèmes
« Reply #9 on: January 26, 2011, 17:43:55 »
Bon ça ne marche pas.
J'ai désinstallé par Synaptic (suppression complète), nettoyé en sus par Ubuntu-tweak, supprimé le répertoire git de GMB, redémarré.
Puis j'ai réinstallé par Synaptic (version des dépôts) pour que GMB soit reconnu comme installé, ensuite j'ai suivi le mode d'emploi du wiki pour la version git, make all, sudo make install. À noter que le nettoyage ne devait pas être complet puisque la configuration au lancement était celle que j'avais avant la désinstallation (le .config/gmusicbrowser est resté en place).

Et finalement j'ai toujours le problème :
Quel que soit le layout (par exemple Listes de lecture Bibliothèque & Contexte) la "liste de lecture" fonctionne mal, à savoir que lorsque je double clic sur un album, par exemple, la liste de lecture n'enregistre que la première chanson de l'album, la joue et s'arrête après la lecture de cette chanson.

Quentin Sculo

  • Administrator
  • Hero Member
  • *****
  • Posts: 1082
    • View Profile
Re: Quelques problèmes
« Reply #10 on: January 26, 2011, 19:47:00 »
C'est normal que .config/gmusicbrowser reste en place. As tu essayer de renommer le répertoire, ou d'utiliser l'option -cfg /tmp/ceci_est_un_test comme je l'ai suggéré ?

mgrubert

  • Sr. Member
  • ****
  • Posts: 369
    • View Profile
Re : Quelques problèmes
« Reply #11 on: January 27, 2011, 00:39:44 »
OK, je viens d'essayer (avec ceci est un test), le problème ne se pose plus.
Il y a donc un problème dans un de mes fichiers de configuration, c'est ça ?
Comment je fais pour trouver lequel ? Pas trop envie de perdre mes multiples listes statiques...
« Last Edit: January 27, 2011, 00:45:16 by mgrubert »

Quentin Sculo

  • Administrator
  • Hero Member
  • *****
  • Posts: 1082
    • View Profile
Re: Quelques problèmes
« Reply #12 on: January 27, 2011, 04:25:36 »
Tout est dans le fichier ~/.config/gmusicbrowser/gmbrc il est divisé en plusieurs sections, la première "[Options]" contient tout ce qui n'est pas données des chansons/albums/artistes.
Si tu veux, tu peux m'envoyer le fichier, ou juste la partie [Options], pour voir si je peux trouver la cause de ce comportement.
Un truc à essayer quand même, quelle option est activée dans l'onglet "Audio", essaye de changer voir si ça affecte le problème.

Les listes statiques sont dans la section [Options] sous la forme de liste de numéros, les numéros correspondent aux chansons dans la section [Songs].
Sinon, il est possible de les exporter et de les importer, mais l'export est une par une pour l'instant :(

mgrubert

  • Sr. Member
  • ****
  • Posts: 369
    • View Profile
Re : Quelques problèmes
« Reply #13 on: January 27, 2011, 08:03:26 »
Je t'envoie le fichier par email.
Le changement de type de sortie dans l'onglet audio ne change rien. Par défaut c'est Gstreamer, détection automatique.
Je m'absente jusqu'à vendredi soir.
Merci de ta disponibilité.

mgrubert

  • Sr. Member
  • ****
  • Posts: 369
    • View Profile
Re : Quelques problèmes
« Reply #14 on: January 29, 2011, 18:40:16 »
Bon écoute, avec un copié collé dans le gmbrc, j'ai récupéré mes filtres et listes statiques, donc tout refonctionne normalement à présent (le reste : la date d'ajout, le nombre de fois joué, etc. ne m'intéresse que modérément).
Donc si tu trouves l'origine du problème, ce sera juste par curiosité (ça m'intéresse de savoir quand même).
Je passe en résolu.


Edit : j'ai parlé trop vite, les numéros des chansons ont du changer puisque les listes statiques ne contiennent pas les bons morceaux. Je vais tenter un export depuis la config qui ne tourne pas, puis un import depuis la config qui tourne, je te tiens au courant.

Reedit : J'ai pris mon plus ancien backup de gmbrc (22 janvier 2011) et non seulement y'a toutes les filtres et listes (ce qui est normal) mais en plus tout fonctionne avec ce gmbrc (Liste de lecture, etc.) donc cette fois je passe en résolu.
« Last Edit: January 29, 2011, 18:52:57 by mgrubert »