Author Topic: GMB should save the imported tracks immediately after import  (Read 1983 times)

Photon

  • Jr. Member
  • **
  • Posts: 21
    • View Profile
Hi!

I observed following behaviour: Sometimes you shut down the computer without quitting GMB properly. In this case the tracks imported in this session are gone from the library and have to be imported again at the next start.

Photon  :)

Quentin Sculo

  • Administrator
  • Hero Member
  • *****
  • Posts: 1082
    • View Profile
Re: GMB should save the imported tracks immediately after import
« Reply #1 on: January 08, 2011, 21:44:32 »
It's not just the tracks added to the library, its also any option, and playcount/rating/.../any value that changed.

What needs to be done, is make gmb session-aware so that it saves itself when the session is closed.
There is currently only support of the gnome, via the -use-gnome-session command line option, that requires some gnome libraries and their perl bindings (libgnome-perl I think).

Nowadays, sessions management is done via DBus, and so doesn't require additional libraries, I need to find documentations on the existing session manager, sadly there doesn't seem to be a standard yet, so I have to support each session manager individually. (links to good documentation welcome)

So currently you should either close gmb properly, use the autosave plugin that saves every x minutes, or use  "-use-gnome-session".

Photon

  • Jr. Member
  • **
  • Posts: 21
    • View Profile
Re:GMB should save the imported tracks immediately after import
« Reply #2 on: January 11, 2011, 01:00:59 »
Thanks, currently I'm just closing it properly but would be nice if it would just work. :)