Author Topic: [Solved] Can't get global shortcut keys to work - Am i missing something?  (Read 4953 times)

helloindustries

  • Jr. Member
  • **
  • Posts: 69
    • View Profile
I've enabled the plug-in 'gnome mmkeys' and the play/pause button on my Microsoft Ergonomic 4000 keyboard responds as expected.

However...
When assigning keys to next/prev (settings>keys) they fail to work unless i have GMB focussed, which isn't much use to me.

I've tried using the back/forward keys on my KB, ctrl + assorted numpad keys, etc, but nothing seems to work. Most frustratingly; I can't assign ctrl+arrow keys to functions.

Any ideas?

SOLVED:

assign following to key combination of choice via: system>preferences>keyboard shortcuts
gmusicbrowser -cmd <command here>


« Last Edit: December 24, 2010, 21:17:06 by helloindustries »

Quentin Sculo

  • Administrator
  • Hero Member
  • *****
  • Posts: 1082
    • View Profile
Re: Can't get global shortcut keys to work - Am i missing something?
« Reply #1 on: December 24, 2010, 03:56:23 »
settings->keys is not for global shortcuts. Global shortcuts don't really have a standard way to be set currently as far as I know, so you must configure them yourselves in your window manager.
see the question "How do I control gmusicbrowser with global shortcuts or multimedia keys" in the FAQ : http://gmusicbrowser.org/faq.html

the command :
 gmusicbrowser -remotecmd PlayPause
will toggle between playing and paused
the command :
 echo PlayPause > ~/.config/gmusicbrowser/gmusicbrowser.fifo
will do the same slightly faster.
You can also send the command through DBus.

use "gmusicbrowser -listcmd" to list the available commands

helloindustries

  • Jr. Member
  • **
  • Posts: 69
    • View Profile
Re: Can't get global shortcut keys to work - Am i missing something?
« Reply #2 on: December 24, 2010, 04:06:42 »
Thanks.

So far i've tried:

Custom command via Ubuntu Tweak / keyboard shortcut settings: gmusicbrowser -PlayPause
And the same again but with: gmusicbrowser -remotecmd PlayPause

But neither seem to work.
I have both the Gnome mmkeys and MPRIS v1 plug-ins active.

Quentin Sculo

  • Administrator
  • Hero Member
  • *****
  • Posts: 1082
    • View Profile
Re: Can't get global shortcut keys to work - Am i missing something?
« Reply #3 on: December 24, 2010, 18:28:58 »
Oh sorry, I copied the line from the FAQ, and forgot I've made a small change in v1.1.x, you now have to run "gmusicbrowser -cmd PlayPause" instead. (I need to update the FAQ answer)
If it doesn't work try running it from a terminal and see what it tells you.

helloindustries

  • Jr. Member
  • **
  • Posts: 69
    • View Profile
Re: Can't get global shortcut keys to work - Am i missing something?
« Reply #4 on: December 24, 2010, 19:59:38 »
Oh sorry, I copied the line from the FAQ, and forgot I've made a small change in v1.1.x, you now have to run "gmusicbrowser -cmd PlayPause" instead. (I need to update the FAQ answer)
If it doesn't work try running it from a terminal and see what it tells you.

Worked perfectly!
Thanks :)