Author Topic: [solved] gstreamer 1.0 not used  (Read 2141 times)

staubi

  • Jr. Member
  • **
  • Posts: 57
    • View Profile
[solved] gstreamer 1.0 not used
« on: April 27, 2015, 19:17:27 »
Since the latest update gmb is supposed to use gstreamer 1.0 but it seems it still uses gstreamer 0.10, without the option to change this...  (see screenshot)

I have glib2, glib-perl and perl-gstreamer installed.

Any ideas?
« Last Edit: April 28, 2015, 21:07:14 by staubi »

Quentin Sculo

  • Administrator
  • Hero Member
  • *****
  • Posts: 1082
    • View Profile
Re: gstreamer 1.0 not used
« Reply #1 on: April 27, 2015, 20:37:13 »
To use gstreamer-1.x you need the perl module Glib::Object::Introspection and the gstreamer introspection data (a file named Gst-1.0.typelib).
On ubuntu these are found in packages libglib-object-introspection-perl and gir1.2-gstreamer-1.0.
You will also need gstreamer-1 itself of course and at least some 1.0 plugins (libgstreamer-plugins-base1.0-0 on ubuntu)

staubi

  • Jr. Member
  • **
  • Posts: 57
    • View Profile
Re: gstreamer 1.0 not used
« Reply #2 on: April 28, 2015, 21:06:39 »
That was fast ;)

I installed "perl-glib-object-introspection" but even though I couldn't find any "gir1.2-gstreamer-1.0" and "Gst-1.0.typelib" package it's working now! Btw I use Arch.

Thanks for Your help!