Author Topic: Genres filter doesn't appear to work.  (Read 1492 times)

mrbo

  • Newbie
  • *
  • Posts: 2
    • View Profile
Genres filter doesn't appear to work.
« on: December 06, 2014, 19:30:28 »
PC: Dell Mini-9
OS: x-Ubuntu 12.10
gmusicbrowser version 1.1.9

Because of the age and size of my PC, this is the latest version of everything I can have. It's a great little system that my brother gave me and with 128 gig flash stick, it provides me plenty of music at the office. Problem is, there are days I want to exclude the classical music.

I use the filter option (little funnel on the lower left hand screen) select "Custom..." Put something in for the name of the filter (Lets say Test) and configure the filter this way

All of:
  Genres doesn't contain Classical
  Genres doesn't contain Organ
  Genres doesn't contain Holiday

I save the filter, select it, but it doesn't appear to remove the classical, organ, and holiday from my selection.

I can do this for the Title of the song just fine. That works.

I make it simpler by just having a filter; Genres contains Rock. It then says "Nothing in the playlist" though I have TONS of stuff under the Rock Genre.

Was there a problem with Genres selection in this version?

Addendum: Year works fine. Artists do not however Artist (not plural) does. I notice that the actual field is Genre (under settings, Fields) but the filter selection is Genres. I wonder if this might have something to do with it?
« Last Edit: December 06, 2014, 20:02:42 by mrbo »

mrbo

  • Newbie
  • *
  • Posts: 2
    • View Profile
I figured it out....
« Reply #1 on: December 07, 2014, 00:27:07 »
The magic word is "Includes", not "Contains" as in

All Of:
  Genres doesn't include Classical
  Genres doesn't include Organ
  Genres doesn't include Holiday.

This helps with my sanity. There are times when I'm developing code that I just don't want slow stuff....

Thank you for this excellent music player!