Author Topic: Will only play one track  (Read 3064 times)

ceandre

  • Newbie
  • *
  • Posts: 2
    • View Profile
Will only play one track
« on: October 16, 2014, 21:17:53 »
I've just reloaded gmusicbrowser after a data crash. Now it will only play one track at a time then an error message pops up saying:  "Failed to open /home/colin/.mplayer/input.conf."

The error details read, for eg: "/usr/bin/mplayer -nocache -slave -vo null -nolirc -hr-mp3-seek -msglevel all=1:statusline=5 -softvol -volume 26.2144 -- /media/colin/345ACD585ACD178E/Music Back-up/John Coltrane - A Love Supreme (2002) Deluxe Ed/A Love Supreme [2002 Deluxe Edition] Disc 1/01 A Love Supreme, Pt. 1- Acknowledgement.mp3"

My library is large, but it used to play Ok before my data crash. I've tried re-loading gmusicbrowser, but no joy. Any suggestions please

Quentin Sculo

  • Administrator
  • Hero Member
  • *****
  • Posts: 1082
    • View Profile
Re: Will only play one track
« Reply #1 on: October 17, 2014, 03:49:24 »
You can try using gstreamer instead of mplayer : go to the audio tab of the preferences dialog and choose gstreamer (if it is grayed out it means you have to install the libgstreamer-perl package)
If gstreamer doesn't work or you want to use mplayer, you can start by looking at /home/colin/.mplayer/input.conf what is its owner/permissions/size, try to open it and see what's in it, rename it.

ceandre

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: Will only play one track
« Reply #2 on: October 17, 2014, 23:03:35 »
Brilliant. Thanks a lot for your help. Took five seconds to fix.

rhizome

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: Will only play one track
« Reply #3 on: July 09, 2015, 05:27:42 »
This post comes up in Google the highest for anything resembling this problem, and now that ffmpeg is falling by the wayside in Debian 8 and gmus hasn't yet updated to gstreamer1.0, I think it's important to have an actual fix for OP's question.

The fix for mplayer complaining about an unreadable input.conf after one song is simply to create an empty ~/.mplayer/input.conf. Press 'play' and gmusicbrowser will happily progress to the next song in the playlist. You don't even have to restart GMB. This doesn't account for broken input.conf's, just missing ones (which mplayer will complain as unreadable).

Quentin Sculo

  • Administrator
  • Hero Member
  • *****
  • Posts: 1082
    • View Profile
Re: Will only play one track
« Reply #4 on: August 04, 2015, 17:34:21 »
Thanks rhizome, sorry for taking so long. I've fixed it in git : http://git.gmusicbrowser.org/commit/8f95c16357