Author Topic: problems with options of mplayer-command  (Read 3506 times)

die_welt

  • Newbie
  • *
  • Posts: 7
    • View Profile
problems with options of mplayer-command
« on: October 06, 2013, 18:59:50 »
Hallo,

I wanted to use the options of mplayer to send all the stereo audio to only one loudspeaker. It works with the command-line:
mplayer '/home/path-to.mp3'   -af channels=1:0:0:0

To check if the command-line-options are really working well, this option is more effective; it reduces the volume in dB (-12dB is a quarter): 
mplayer -af volume=-12 '/home/path-to.MP3
 
But if I set this in the "Erweiterte Einstellungen" (suppose it is extended configuration in English) in audio-tab with mplayer choosen, nothing changes in the playback of gmusicbrowser. If I stop and play another song it is still behaving as if there isn't any parameter set. I tried to close and reopen the application gmusicbrowser - no difference in behaviour.

Do you know why?

With commandline mplayer it works. It seems like the parameter aren't read and applied in gmusicbrowser.

In this "Erweiterte Einstellungen" the first line says "mplayer Befehl" (translated mplayer-command); what does this mean? I have written there mplayer - is that right?
The second line is "Mplayer-Optionen". I put there in:       -af volume=-25

What is the problem?




A feature request is to implement
  • a free command line in this audio output, for example with %t for the title-string
or

bucaneer

  • Jr. Member
  • **
  • Posts: 33
    • View Profile
Re: problems with options of mplayer-command
« Reply #1 on: October 06, 2013, 20:13:41 »
Both of these commands ("-af channels=1:0:0:0" and "-af volume=-12") work for me in gmusicbrowser. Maybe you forgot to set mplayer as your output in the Audio tab? The mplayer options would have no effect if you were still playing through gstreamer.

die_welt

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: problems with options of mplayer-command
« Reply #2 on: October 06, 2013, 22:44:53 »
Hm, strange.

I donĀ“t understand, why it is not working here?

May you see at the screenshot the mistake? quotes? wrong command?
How does this take effect? With a restart of the application? with the next song played?

Thanks for your help

bucaneer

  • Jr. Member
  • **
  • Posts: 33
    • View Profile
Re: problems with options of mplayer-command
« Reply #3 on: October 06, 2013, 23:37:58 »
OK, I was mistaken - the volume command does not work from gmusicbrowser - I assume it is cancelled out by the gmb's own volume settings. However, the channel command does work (I also use "-af equalizer" regularly). Your screenshot looks good - try entering "-af channels=1:0:0:0" instead of "-af volume=-25" and it should take effect on the next song.

die_welt

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: problems with options of mplayer-command
« Reply #4 on: October 07, 2013, 02:05:58 »
ah, okay, so it works - but not with the volume. (which was my validation proof;-)

Thank you very much for investigating and helping.

die_welt

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: problems with options of mplayer-command
« Reply #5 on: October 12, 2013, 01:18:02 »
Because of only the addition of the left and right signal I searched the internet for a better solution.

Especially with loud mixed songs otherwise it sounds horrible; because the output is digitally overloaded.

The ladspa-plugin "Matrix: Stereo to MS (matrixStMS, 1420)" from Steve Harris works much better:
http://plugin.org.uk/ladspa-swh/docs/ladspa-swh.html#tth_sEc2.70

the mpayer-command for a matrix-stereo-to-mid-side
mplayer -af ladspa=/usr/lib/ladspa/matrix_st_ms_1420:matrixStMS '/home/path.to/eels - beautiful freak/05  not ready yet.mp3'
or:
-af ladspa=/usr/lib/ladspa/matrix_st_ms_1420:matrixStMS
as option
« Last Edit: October 12, 2013, 01:22:13 by die_welt »