gmusicbrowser Forum

Main board => Questions => Topic started by: distrodan on March 14, 2016, 23:12:29

Title: Started getting GStreamer installation playing error
Post by: distrodan on March 14, 2016, 23:12:29
I just wanna say that when I recently switched to Linux, my iTunes replacement was what I was most apprehensive about, and when I tried gmusicbrowser I was in love, its just great.

Recently I started getting this error when I try to play something in gmusicbrowser, and I can't work out why or how to fix it (I've tried reinstalling).

ElementaryOS freya 64-bit

Quote
Playing error : Your GStreamer installation is missing a plug-in. at /usr/bin/../share/gmusicbrowser/gmusicbrowser_gstreamer-0.10.pm line 137.

could anyone suggest how to fix this?

Much appreciated!

distrodan
Title: Re: Started getting GStreamer installation playing error
Post by: distrodan on March 14, 2016, 23:28:01
I just found a workaround my installing mpg123 and using that as the output in gmusicbrowser, this only allows mp3 playback though so its not ideal
Title: Re: Started getting GStreamer installation playing error
Post by: bucaneer on March 15, 2016, 22:32:44
Make sure you have gstreamer plugin packages installed, e.g. try running this in terminal:
Code: [Select]
sudo apt-get install gstreamer0.10-plugins-base gstreamer0.10-plugins-good gstreamer0.10-plugins-bad gstreamer0.10-plugins-ugly