Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - bk201

Pages: [1]
1
Suggestions / Re: mplayer gapless with fifo
« on: April 16, 2010, 17:53:16 »
Actually, I just tested this by putting mplayer options

Code: [Select]
-ao pcm:nowaveheader:file=/home/user/gmbfifo
into gmusicbrowser and then creating a pipe

Code: [Select]
mkfifo /home/user/gmbfifo
and then an aplay instance

Code: [Select]
aplay -t raw -c 2 -f S16_LE -r 44100 /home/user/gmbfifo
And it works beautifully when playing any audio from the library!  8)

2
Suggestions / mplayer gapless with fifo
« on: April 16, 2010, 17:47:27 »
In regards to getting gapless playback with mplayer...

If a named pipe is used to stream the audio, linux does enough buffering to achieve gapless playback. Just set up aplay to read from a pipe and use mplayer to send raw pcm to the pipe.

Code: [Select]
$ mkfifo audiofifo
$ aplay -t raw -c 2 -f S16_LE -r 44100 audiofifo &
$ mplayer -ao pcm:nowaveheader:file=audiofifo <audio files>

Ideas taken from http://www.volkerschatz.com/hardware/itxplayer.html (scroll down to software/audio player)

3
Questions / Re: gstreamer issue with 1.1.4
« on: February 24, 2010, 04:46:38 »
FWIW this behavior is the same with or without the gapless option enabled.

4
Questions / gstreamer issue with 1.1.4
« on: February 23, 2010, 09:30:48 »
Craving some gapless goodness I decided to try 1.1.4 with gstreamer. Previously I was using 1.0.2 with mplayer and didn't even have gstreamer installed on my system. After installing gstreamer and flac, mp3 and ogg support (tested to work with aplay and gst-launch) I started 1.1.4 with the gapless box checked and all is well... except it seems to randomly lose the connection to gstreamer. Sometimes its after sitting idle for a while or after one album plays through and I start another one, sometimes just randomly. The progress bar stays at zero and nothing happens when I try and start a song. Restarting gmb fixes this, as does changing to the mplayer backend instead without restarting, though switching back to gstreamer only works with restart. I'm not sure if the issue is my new gstreamer setup or with alpha gmb, but I figured I could provide useful feedback either way.

5
Questions / Re: Using USB Audio
« on: February 23, 2010, 09:21:53 »
I have successfully used USB sound cards with the mplayer backend by exporting the environmental variable ALSA_CARD=<card name> before starting gmb. For me the USB card is named "default" (dunno why) so I just do

~$ ALSA_CARD=default gmusicbrowser

and use the mplayer backend. There could be a better way to do it but this works for me.

Pages: [1]