Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - crism

Pages: [1]
1
Questions / Re: Spontaneous skips: why?
« on: October 12, 2013, 08:30:42 »
Thanks for the quick detective work, Quentin. I can live with it for now, though it’s a slight pain… the baffling part to me is that these files *did* play a few times, then stopped working, but I suppose an upgrade in gstreamer could account for that.

I’ll keep my eyes open for a future version using gstreamer 1.0, and will muddle through meanwhile.

Thanks, and sorry for the e-mail hassles.

2
Questions / Re: Spontaneous skips: why?
« on: October 12, 2013, 02:47:42 »
crism: sorry but I still haven't seen any email from you (checked all accounts, including spam folders).

Well, crap—tried again just now. Perhaps the bad wireless caused a glitch last time… sorry for all the hassle.

3
Questions / Re : Re: Spontaneous skips: why?
« on: October 05, 2013, 01:56:29 »
Sorry but I haven't seen any email from you. Could you try again ? You can use the email squentin at gmail.com

I used the in-forum e-mail link on your profile. Direct e-mail is now queued up. (Currently on a wireless that won’t allow SMTP connections.)

Thanks again.

4
Questions / Re: Spontaneous skips: why?
« on: October 03, 2013, 02:25:58 »
Can you send me one of these files by email (as a link if it is too big) ?

Done. Thanks, Quentin!

5
Questions / Spontaneous skips: why?
« on: September 24, 2013, 08:14:25 »
I have a large(ish) music library, mostly in FLAC format, and continue to love using gmusicbrowser to play it.

However, some tracks start to play, then spontaneously move on to the next track in the queue.

The tracks are not damaged (at least not obviously); they play just fine in VLC or other media players.

The skip is consistent, at the same time; for instance, the one just now that provoked this post skips at 0?14? every time. When this happens, the skip count is incremented, so gmusicbrowser definitely doesn’t think it’s reached the end of the track.

This happens with probably about a dozen tracks out of almost ten thousand in my collection, but of course they are among my favorites.

The behavior did not always exist; for example, the track this evening did play successfully 4 times (at some point in the past). Once a track starts skipping, it seems irreversible.

Any idea what’s going on here, or what I can do to fix it?

This is gmusicbrowser 1.1.9, using gstreamer for output, on Linux Mint 15 Olivia.

6
Questions / Re: Playlist filtering by label not set seems broken
« on: March 22, 2011, 04:16:30 »
Right, I forgot about the optimization used when many values are used : rather that checking each song for each value, a hash is made to quickly check if the value is in the list.

there was indeed a small bug in v1.0.2, which resulted in -$r at the end of the code, rather than !$r :)
I fixed it in git v1.0.x branch, though there won't be any more release of that branch :
http://git.gmusicbrowser.org/commit/743b7436c0

The bug is not present in v1.1.x.

Thanks for all your time, Quentin. I’ll live with it for now, and petition the Ubuntu gods to update their distro while I upgrade independently.

7
Questions / Re: Playlist filtering by label not set seems broken
« on: March 22, 2011, 01:43:24 »
First I doubt there was any update of gmusicbrowser in your system recently as sadly v1.0.2 is very old, though it is the last officially "stable" version (v1.1.7 should be present in the next ubuntu).

I’ll keep my fingers crossed for the update.

I tried with both the latest and with v1.0.2 and it all seems to work, so I would guess it is probably some confusion with what filter is currently applied.
When running gmusicbrowser with the -debug option, you can see the actual code that is used for the filter, I get :

I hadn’t thought of trying that, thanks. I think I can prove I’m not crazy. (-:

I had Any of: set, and when I ran with -debug:

Code: [Select]
$sub=eval sub{ [ grep {($::Songs[$_][23]!~m/(?:^|\x00)broken(?:$|\x00)/ || $::Songs[$_][23]!~m/(?:^|\x00)redundant(?:$|\x00)/ || $::Songs[$_][23]!~m/(?:^|\x00)skip(?:$|\x00)/ || $::Songs[$_][23]!~m/(?:^|\x00)spoken\ word(?:$|\x00)/ || $::Songs[$_][23]!~m/(?:^|\x00)yule\ only(?:$|\x00)/)} @{$_[0]} ]; }


which is fine. Changing the playlist back to All of: and running with debug, I see something much different; the full output is included up to that point here:

Code: [Select]
watch AAPicture HASH(0xa1d7678)
GStreamer::Interfaces perl module not found -> visuals not available
Reading saved tags in /home/crism/.config/gmusicbrowser/tags ...
Reading saved tags in /home/crism/.config/gmusicbrowser/tags ... done
Use of uninitialized value in join or string at /usr/bin/gmusicbrowser line 2173.
Use of uninitialized value $_[9] in join or string at /usr/bin/gmusicbrowser line 2173.
Select : filter Filter=HASH(0xaa1cbe0) sort r1l10 song keep play  staticlist
makesub filter=(&-23fbroken-23fredundant-23fskip-23fspoken word-23fyule only)
filter=(&-23fbroken-23fredundant-23fskip-23fspoken word-23fyule only)
$sub=eval sub{ [ grep {do { my $r;exists($hashes[0]{$_}) and $r=1 and last for split /\x00/,$Songs[$_][23];-$r;}} @{$_[0]} ]; }
ChangeWatcher 0 ARRAY(0x927bf90) ARRAY(0xa6e2990) CODE(0x9d29f78) CODE(0x9d2a408) CODE(0x9d1ef48) Filter=HASH(0xaa1cbe0) CODE(0x9d2a108)
filter fields : '23'
pos : 126

That is a very different filter, obviously. I can confirm that the “everyday” filter is currently applied, and that it is defined as All of: a bunch of label-not-sets. The only thing I did between those two runs was to edit the playlist, change Any of; to All of:; save it; re-apply it, then quit and restart.

Looks like I should try to upgrade on my own and see if it persists.

8
Questions / Re: Playlist filtering by label not set seems broken
« on: March 21, 2011, 19:48:57 »
Thanks for the reply, laite. More info follows:

If you want just shuffle, you could build 'weighted random' option where you can select labels you don't want to be played (set weight = 1, and check [ x ] inverse for all of them)

A good suggestion. I’ll try that, though I’d still like the ability to easily save these different label-based playlists.

How can I build a playlist based on negative filtering of labels?

I have no problems with
"All of:
 * label A isn't set
 * label B isn't set
 ...
"
It results as a playlist containing only songs with no labels. Are you sure your 'playlist filter' is set to use this filter instead of 'all songs'? Can you see those unwanted songs in your filtered playlist (to check this, for example insert column "labels", sort by clicking it and check first and last song of list)?

Good diagnostic suggestion—when I display labels, and use the playlist as a filter, the undesired labels definitely show up.

I suspect that the “label X isn’t set” filter works differently than I think. Lemme get Boolean for a minute…

I think of “label X isn’t set” as not(X(t)) where t is a track, and X(t) returns true if the label is set; !X for a shorter notation.

I would expect All of: to be a logical and, and Any of: to be a logical or.

With All of: Label X isn’t set, Label Y isn’t set, I would expect and(not(X(t)),not(Y(t))), or: !X and !Y. Now, !X and !Y is equivalent to !(X or Y), exactly what I want.

But what I get with All of: is only the undesired labels, i.e., X or Y. It seems like All of: with the negative label assertion is broken.

With Any of: Label X isn’t set, Label Y isn’t set, I would expect or(not(X(t)),not(Y(t))), or: !X or !Y. This is equivalent to !(X and Y).

That should show all the tracks, unless they have all the undesired labels set. Indeed, this works; when I add all the bad labels to one track, it falls off the playlist. However, a couple of weeks ago (and maybe there was an update in between), I was getting the desired behavior, !(X or Y).

It really feels to me like there is some mis-applied De Morgan going on inside the system. (-:

Oh, information I should have included in the post which was the very top of this thread: this is gmusicbrowser 1.0.2, installed from the package manager for Ubuntu 10.04 Lucid Lynx.

Thanks.

9
Questions / Playlist filtering by label not set seems broken
« on: March 21, 2011, 01:00:01 »
Thanks for the great player. Long time user, first-time poster…

By default, I like to have all my music on shuffle, except for a few tags (broken tracks, redundancies, Christmas music, etc.).

I set up a playlist called “Everyday”, defined as:

All of: Label broken isn't set; Label redundant isn't set; Label skip isn't set, etc.

When I do that, all my tracks are in the playlist, even the ones with those labels set.

When I switched to Any of: to my surprise, it worked — a couple of weeks ago. Today, I was surprised with some spoken word and Christmas music. Any of: seems to have changed, but All of: is still the same.

Am I doing something wrong? Is this a gmusicbrowser bug? Advice greatly appreciated.

tl;dr: How can I build a playlist based on negative filtering of labels?

Pages: [1]