I'm going to rename some layout widgets, some of them have very bad names. The old names will still work, unless I need to re-use the name for a new widget.
Here's the current list of renaming, I'm still not sure on a few of them, suggestions are welcome.

old name => new name
Playlist => OpenBrowser
BContext => OpenContext
Pos => PlaylistPosition
Date => Year
Scale => TimeScale or TimeSlider
VolSlider => VolScale or keep VolSlider
Label => Text
LabelTime => Time
Vol => VolumeIcon
LabelVol => Volume
FPane => FilterList or FilterPane
FLock => FilterLock
TogButton => ToggleButton
SimpleSearch => Search or keep SimpleSearch ?
ProgressV => VProgress
FBox => FilterBox
AABox => AlbumBox and ArtistBox
AASearch => AlbumSearch and ArtistSearch ? (more or less deprecated anyway)


I also plan to rename a few widget options :
- rename the "label" option to "text" (I realized only a few months ago that the numerous use of "label" in the layout doc to mean "text" was very confusing with the "labels" song field.)
- rename the "nb" option to flevel ? something else ? this option is used in particular in the FPane widget to set the filter level (when filter n is set, all filters>n are reset)

the renaming makes pretty much sense to me.

a few suggestions:
Scale -> TimeScale
VolSlider -> VolumeScale
ProgressV -> VProgressBar ?
nb -> filterlevel?

(i know some of my proposals are more verbose and therefore longer, but that seems to be a general tendency of this renaming.)

a question: will Time (formerly LabelTime) include Length? (as in: $position of $ length)
if not, it would be nice to be able to define the separator between the two (like "/" instead of "of"). and there's an alignment problem currently if you want to have both right-aligned in an HBox.

I've made a commit : http://git.gmusicbrowser.org/commit/d92592a2a0
I opted for VolumeSlider and TimeSlider as it's maybe clearer
VProgressBar doesn't really fit because it's not only a bar, there is some text above it.
I haven't renamed Pos yet, as PlaylistPosition is a little too long, maybe Position. Though it's not only the position, it displays the number of songs in queue for example.

About filterlevel, it's a little long for an option that is almost mandatory for FilterPanes, so I'm still not sure.

And about LabelTime (now PlayingTime) and Length, I've made a new widget Time that combines the 2. The string format can be redefined, though currently you'd need to redefine markup, markup_empty and initsize to make it properly :(  (markup_empty is for when no song is selected, initsize is a string used to determine the initial size, it is used so that the widget doesn't grow when changing song.)