September 08, 2011, 15:13:36 Last Edit: September 13, 2011, 11:04:41 by cardiacanesthesia
i changed my Distro to oneiric beta
installed gmb latest from andreas' repo
home folder is a different partition than root
and music is a different partition NTFS
left the .config and gmbrc  etc as such
but now, it is reading all the tags and playing songs nicely, but doesn't add a new folder when added
i checked add/ scan new folders on startup , but the newly added folders don't show up
i even tried to use a backup gmbrc but same problem persists
anything i did wrong?

the output for running gmusicbrowser in terminal is
GStreamer::Interfaces perl module not found -> visuals not available
No plugin found in /home/subodh/.config/gmusicbrowser/plugins/, maybe it uses an old format
Reading saved tags in /home/subodh/.config/gmusicbrowser/gmbrc ...
plugin /home/subodh/.config/gmusicbrowser/plugins/ failed : Can't locate Text/ in @INC (@INC contains: /usr/bin/../share/gmusicbrowser /etc/perl /usr/local/lib/perl/5.12.4 /usr/local/share/perl/5.12.4 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.12 /usr/share/perl/5.12 /usr/local/lib/site_perl .) at /home/subodh/.config/gmusicbrowser/plugins/ line 92.
BEGIN failed--compilation aborted at /home/subodh/.config/gmusicbrowser/plugins/ line 92.

plugin /usr/bin/../share/gmusicbrowser/plugins/ failed : Can't locate Gtk2/ in @INC (@INC contains: /usr/bin/../share/gmusicbrowser /etc/perl /usr/local/lib/perl/5.12.4 /usr/local/share/perl/5.12.4 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.12 /usr/share/perl/5.12 /usr/local/lib/site_perl .) at /usr/bin/../share/gmusicbrowser/plugins/ line 22.
BEGIN failed--compilation aborted at /usr/bin/../share/gmusicbrowser/plugins/ line 22.

@Fields=album_shuffle replaygain_album_gain skipcount file grouping replaygain_track_peak list title bitrate added channel title_or_file size album_artist_raw shuffle playcount replaygain_track_gain version path length disc year barefilename fullfilename_raw compilation modif lastskip replaygain_reference_level genre embedded_pictures label replaygain_album_peak samprate filetype missing rating lastplay embedded_lyrics extension track artist comment ratingnumber artists first_artist version_or_empty uri artist_picture fullfilename album album_picture missingkey album_years album_artist at /usr/bin/../share/gmusicbrowser/ line 1273.
adding update code for artists at /usr/bin/../share/gmusicbrowser/ line 1392.
Reading saved tags in /home/subodh/.config/gmusicbrowser/gmbrc ... done
These commands were not found : flac123, ogg123
=> these file types won't be played by the 123 output : oga, flac
Subroutine IsFieldSet redefined at /home/subodh/.config/gmusicbrowser/plugins/ line 37.
Subroutine AddRatingPointsToSong redefined at /home/subodh/.config/gmusicbrowser/plugins/ line 47.
Subroutine GetRulesBySignal redefined at /home/subodh/.config/gmusicbrowser/plugins/ line 72.
Subroutine gettimeofday_us redefined at /home/subodh/.config/gmusicbrowser/plugins/ line 85.
/org/mpris/MediaPlayer2 at /usr/bin/../share/gmusicbrowser/plugins/ line 30.
SongArray_changed replace,
SongArray_changed proxychange,
SongArray_changed replace,
MakeFilterFromGID => first_artist:~:Mohammed Rafi at /usr/bin/../share/gmusicbrowser/ line 1754.
found another ID3v2 tag

pls help

Are you running KDE ? someone reported a bug which prevent the idle tasks from running when using KDE, I still haven't managed to find the cause :(

No , I am using Gnome 3 with unity
i somehow managed to add the songs by changing layouts . i know it is not possible that way but somehow in a particular layout when i rescanned folders , it just worked
but now a new problem
sometimes the song starts playback, and by clicking next song button, the player just exits
and lastly it gave this error
Playing error : Failed to parse stream at /usr/bin/../share/gmusicbrowser/ line 135
have i not installed proper gstreamer codecs?

about not adding songs, can you reproduce it by re-using the layout and do a few tests for me ?

About the rest, can you run it from a terminal to see what it says.
Is the "Failed to parse stream" error specific to one song, or just random ?

sorry for delayed response
i changed the default layouts for traytip and fullscreen.
it had some problems with shimmer traytip i guess due to GTK2
and after that things are running quite smoothly

and yes the problem of not adding is somehow related to layout, it does scan songs in my cardiacanesthesia layout and doesn't in the queue, library and context layout

so lastly, things are going pretty smooth
one more thing, while choosing filters for making a custom dynamic playlist, can you add a single selector for "any text field" in the metadata?
music in India is mostly contained to movie soundtracks, there are not many artist oriented private albums classified by genre and so on
one movie may host songs of 5 different genre sung by 4 different singers as solo and duets and written by another set of people
so it is very difficult to classify it with the usual music player categories.
so if i want to search for all tracks in which mr X is involved as a lyricist or composer or singer , i have to add three lines in filter
and if the search involves two more persons it becomes 9 different lines
had it been "any text field" contains "mr x" it would have been very easy to find.

sorry for long post
thanks for the help
dr subodh

About the not adding, can you try removing the "#" in front of the lines
#New => sub { Gtk2::HBox->new(::FALSE,0); },
#New => sub { Gtk2::VBox->new(::FALSE,0); },

in (around line 2105) (installed in /usr/share/gmusicbrowser/)
and see if it still have the problem ?

About searching in all text fields, I will think about it. One solution currently is to use the SimpleSearch widget to create the filter, you can select the default filters in the menu you get when clicking on the left icon, you can also search for things like :
artist|title|album:"some artist name"|"another name"
or simply by using the selected fields :  "some artist name" | "another name"

you can then edit/save the filter by choosing "Advanced search..." in the left icon menu.

well , tried the first thing and it DID WORK.
thanks for that

secondly for now the idea of a pipe character is as good as selecting it like "any text field". i selected all options from the simple search box left click menu and then used pipe character for 2 different artists
this ROCKS

Dr subodh