I'm using version 1.0.2.  I don't have any particular DE on my linux and I use pcmanfm as file manager.  When I click on "open containing folder" nothing happen.  Can I have "open containing folder" point to pcmanfm?

gmb use the xdg-open script (that is supposed to find the correct command) to open folders or url, but there is a way to override this by setting the OpenFolder or OpenUrl options.
Currently these options can't be set via the gui (maybe I should change that), but you can run this command to change it in a running gmb :
gmusicbrowser -remotecmd RunPerlCode '$::Options{OpenFolder}="pcmanfm"'

I edited xdg-open script to behave appropriately for my system.  I agree these options should be available in the gui in the next version.  Thanks.