Gapless playback is very important for me. I have lots of classical music and mix albums. So I enabled gapless playback in preferences, but it doesn't work.

I searched this forum and followed this instruction:

But Synaptic does not show me anything to update. Well, the forum post is from February. So perhaps the gstreamer version was succeeded already.

Anyway, I cannot get gapless playback in gmusicbrowser in Ubuntu 12.04 64-bit. And I don't know why. My mp3 files are encoded with Lame encoder and have the Lame tag. It works with Audacious and DeadBeef. But gmusicbrowser plays with gap.

What can I do?

I don't know, I've tested it with some songs and as far as I know, it works, and I know some people confirmed it worked for them too.
Can you send me by email (via a file hosting service or something) an example of 2 songs that you have tested, and that works with other programs ?


I've sent you a link to where I uploaded the example songs.

Also, I checked once more with tagger software kid3-qt to see if the Lame tag is there. It's there (TSSE), as well as length info (TLEN).

In DeadBeef the gapless playback is perfect. In Audacious it's near perfect, just an almost inaudible crackle of perhaps 7ms, but no pause, hence gapless. I assume these players buffer the tracks in their own specific way to achieve gapless for mp3.

But all other audio players fail (Rhythmbox, Clementine, guayadeque, Banshee etc). So I think it must be a problem of the libraries (gstreamer bug?). I also tried with mplayer, but same problem. Installed then mplayer2 and set gmb to use it, because it's said to be able to do gapless playback, but no luck either.

Or is there something I overlooked? If I mark the checkbox for gapless playback in gmusicbrowser, do I have to enter any value in those fields for the output device (ALSA, JACK, etc)? By the way, how can I see which output gmb has chosen when set to 'auto detect'? I assume, it's ALSA?!

I must say I mostly listen on random, so I rarely test gapless playback.
I did a few quick tests, and with mp3 files (including the ones you sent me) it seems it doesn't work, at least on ubuntu 12.04. It works with ogg files.
You're right that it must be a problem with gstreamer, as gmb lets gstreamer handle it, it just tells it what file is next. So I'm afraid there is not much I can do about it :(

As for mplayer, gapless using mplayer can't work currently with gmb, as it launches a new mplayer process for each file. This is because last time I tried with mplayer in slave mode, I couldn't get a signal (output) telling me that the track was finished. By using one process per track, the process ends when the track ends.

Thank you a lot for your efforts. I already assumed it's a gstreamer problem. I did a bit of more research and it seems I'm not the only one having this problem. Nevermind. Hopefully gstreamer gets a fix soon.