I have installed the gnome-applet-globalmenu (http://code.google.com/p/gnome2-globalmenu/). The result is, i have a menu for gmusicbrowser, but not happens on a click.
Please help, i love this player and it makes me very unhappy :'(

The gmb menus are not very standard because of the way I fill them only when needed. I know that's why I could make them work with keyboard accelerators, and it's probably also the problem with global-menus.
I plan to make them always filled (by updating them each time a change has been made), which should fix this problem.

In the meantime, I know that adding this line :
after the first line of /usr/bin/gmusicbrowser (gmusicbrowser.pl if not installed) will disable the global-menu for gmusicbrowser, so that at least the menu works.
Another way to do it is by launching gmusicbrowser via a shell script such as this one :
exec gmusicbrowser

Both dnoesn't works for me. First I try the shell script, and than the line in /usr/bin/gmusicbrowser; no usable menus.

I love gmb!
The property in menu applet to show the menu also in the applications inside is no option for me, sorry  :-\

it seems there is another way to load modules than using GTK_MODULES.
Looking at the gnome2-globalmenu doc, there is a way to disable it for specific apps by using GTK_MENUBAR_NO_MAC.
So you can put :
export GTK_MENUBAR_NO_MAC="gmusicbrowser gmusicbrowser.pl $GTK_MENUBAR_NO_MAC"
in for example ~/.bashrc or ~/.bash_profile, and then logout
(the gmusicbrowser.pl is only there in case you want to run a non-installed version)