Author Topic: Strange Text Behavior  (Read 2677 times)

jorje_villafan

  • Newbie
  • *
  • Posts: 6
    • View Profile
Strange Text Behavior
« on: December 14, 2009, 10:19:50 »
Whenever a dropdown box appears over the currently playing song info it leaves a ghost image behind the text. If I mouse over it, the ghost disappears. Happened in 1.02 and 1.13. Not sure if it's my set up or not.

 

Thanks for this awesome music solution. It is by far the best for large libraries..... Imho.

Quentin Sculo

  • Administrator
  • Hero Member
  • *****
  • Posts: 1082
    • View Profile
Re: Strange Text Behavior
« Reply #1 on: December 14, 2009, 21:16:42 »
Yes, thanks for reporting this, someone else reported it a couple of days ago. It took me a while to reproduce it in some cases, it seems to happen much more in some system configuration, I don't know which ones. I found that for some reason, using strange utf8 characters, like "????" makes it happen much more reliably.
It is a bug revealed by the new gtk versions that use client-side windows.

It can be worked around by setting the environment variable GDK_NATIVE_WINDOWS to 1 before running gmusicbrowser :
Code: [Select]
GDK_NATIVE_WINDOWS=1 gmusicbrowseryou can also set it by adding the line :
Code: [Select]
BEGIN { $ENV{GDK_NATIVE_WINDOWS}=1; }at the top of /usr/bin/gmusicbrowser, before "use Gtk2".

I've just fixed it in git (in both v1.0.x and master) by simplifying the code used to draw these labels. I actually don't know why I made it so complicated in the first place, I guess I know gtk better now. By the way, it happens with Title/Artist/Album because I make them scrollable in case the text is too long.
commit for v1.1.x : http://git.gmusicbrowser.org/commit/6d2da66f71f8ddc36ddbcd8c07af6aeedd5d90a5
commit for v1.0.x : http://git.gmusicbrowser.org/commit/3d07a02441269a8d97aaeb957d901d0eb2908e6c

jorje_villafan

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: Strange Text Behavior
« Reply #2 on: December 14, 2009, 22:28:57 »
That worked perfectly for me. Thank you very much.