Author Topic: Strange notiy-box in ubuntu karmic  (Read 3492 times)

Aeos

  • Newbie
  • *
  • Posts: 6
    • View Profile
Strange notiy-box in ubuntu karmic
« on: December 10, 2009, 00:03:09 »
Hi,

I installed gmusicbrowser 1.02 from your repository in ubuntu karmic koala and I'm facing a problem with the notify-plugin. Instead of fading a bubble in the top-right corner, a simple box with buttons appears. Any idea why this happens?

Here is a screenshot with the box.
http://ubuntu-pics.de/bild/33699/bildschirmfoto_FrVgar.png
« Last Edit: December 10, 2009, 00:17:30 by Aeos »

Quentin Sculo

  • Administrator
  • Hero Member
  • *****
  • Posts: 1082
    • View Profile
Re: Strange notiy-box in ubuntu karmic
« Reply #1 on: December 10, 2009, 01:33:28 »
Ubuntu's default notify daemon does not support action buttons in its notifying bubble. It seems they have decided to display a dialog  ??? instead when the application request action buttons.
You just need to disable the "Display stop/next actions" option in the notify plugin. It is also possible to replace the ubuntu's notify daemon by the other one (can't remember their names).

Aeos

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re:Strange notiy-box in ubuntu karmic
« Reply #2 on: December 10, 2009, 23:56:38 »
Oh, simple solution. I spent an hour trying to fix it.

Thanks for your help and thanks for the great gmusicbrowser. :-)

Sven

  • Jr. Member
  • **
  • Posts: 32
    • View Profile
Re: Strange notiy-box in ubuntu karmic
« Reply #3 on: December 11, 2009, 04:09:47 »
Did you install libgtk2-notify-perl? Because it just works for me under Karmic. I'm using 1.1.3 git though, so that might also make the difference.

Oh, and you could also try something like "notify-send -i %c %t %a" with the now playing plugin. That's what I used in Jaunty. You might need to do "sudo apt-get install libnotify-bin" for that.